« Hello, Wisconsin! | Main | Friendpimping 7/19/06 »

July 19, 2006

Die Movable Type 3.3 Die

Gaaaaah. I'm officially giving up on upgrading to Movable Type 3.3 because no matter what I do, I cannot convince the new install that there is, in fact, a bootstrap.pm right where any idiot can see it, and I am not nearly technically accomplished enough to fiddle with the scripts to make it work. Perhaps one day some geek will take pity on me and do this thing I'm clearly too lame to do, but until then you're all stuck with lousy Movable Type 3.2, and I'm left to mutter about how this is a conspiracy on the part of Six Apart to try to get me to move to TypePad or something. It's not going to work, Six Apart! I laugh at your one gig of disk space and 10 gigs of bandwidth! I've got 150 gigs of Web space, and 1.5 friggin' terabytes of bandwidth. Ha! I say. Ha! I don't need your lame, annoying, delicious, shiny upgrade anyway.

Stupid Movable Type 3.3.

Interestingly, as I was running the Perl script checker for, oh, the 13,000th time today, I noticed that my host is now offering Wordpress for its users; all you have to do is fill in a couple of lines on a form, pick a template and bam: You've got blog. See? Don't bookmark that, by the way, since I don't intend to keep it -- or, at least, don't intend to keep that particular set-up, because the templates my host provides aren't very flexible. You can't put in your own designs or anything. Also, I can't find the database that goes with the blog, and I find that, well, disheartening. But it's interesting that blog software comes standard now.

In any event, I've wasted too much time trying to update the site. I'll save any other major projects for after I'm done with The Last Colony. And that will give me time to plot my revenge against Movable Type 3.3. Oh, yes. Vengeance will be mine.

Posted by john at July 19, 2006 12:00 AM

Trackback Pings

TrackBack URL for this entry:
http://www.scalzi.com/mt2/mt-tb.cgi/3939

Comments

David Goodman | July 19, 2006 03:21 AM

Of course, you could just go for using Wordpress as an install on your site. It's dead easy to use, promise!

I love it, and all I've ever heard from MT users (yourself, Wil Wheaton) is 'gah, I can't get this to work!' - to the point Wil Wheaton has abandoned his main blog and gone to Typepad. He's rebuilding it, apparently.

Oh yeah, Wordpress does automated imports of MT databases.

Try it on a fresh subdomain, you'll love it.

Mary Robinette Kowal | July 19, 2006 04:16 AM

I use Wordpress and there are tons of templates out there and it's easy to customize. It's also open source and free, so there are tons of plugins to offer additional functions.

Deanna Hoak | July 19, 2006 07:05 AM

LOL! I posted yesterday about stubbornness and finally giving up on fixing the new web page I'm trying to set up.

I really had loaded it thousands of times. I'm going to hire the rest out; I get too obsessed. :-)

Jp | July 19, 2006 07:24 AM

Don't know anything about MT, but if it's a set of Perl scripts that can't see a module (as the .pm suggests), try adding the line:

use lib ('/path/to/directory/containing/the/file/');

to the top of the scripts which aren't working.

Chang | July 19, 2006 09:31 AM

I wish I had time to figure out Wordpress. For now, my blog is lame.

This whole venture soudns like one of those OCD moves I pull whne I have something big looming, like say... a deadline! I usually decide I need to rearage some furniture or rebuild my studio when taxes are due or I am supposed to call some creditor.

But I'm sure that doesn't happen to... writers. :)

John Scalzi | July 19, 2006 09:33 AM

Re: Wordpress -- I'm not entirely sure how installing completely new blog software is going to be easier than staying with what I have.

JP: Tried it. Wasn't working.

Kevin Q | July 19, 2006 09:44 AM

Installing Wordpress is just about the easiest thing in the world. Of course, getting everything set back up so that it looks like the Whatever might take some time, but the installation itself is three steps that take about 5 minutes, total.

I recently upgraded one of my Wordpress blogs, and while it was slightly more complicated than the initial install, it still went smoothly.

Consider this another comment in favor of using Wordpress

K

Kevin Q | July 19, 2006 09:46 AM

What do you know: Wordpress has a help guide for moving from MT:

http://codex.wordpress.org/Importing_from_Movable_Type_to_WordPress

K

Ben Gray | July 19, 2006 09:48 AM

I used to use Movable Type 3.2 and then when my DB crashed I switched to Wordpress and have never looked back. I'm telling ya, Wordpress is WAY easier and more powerful to use than Movable Type.

BTW, now would be an ideal time to switch over ;).

John Scalzi | July 19, 2006 09:48 AM

Yes, but again: How is converting to an entirely new blogging program easier than doing nothing? I don't hate Movable Type. I'm just not technically competent enough to get the latest version to install.

Ben Gray | July 19, 2006 09:49 AM

"How is converting to an entirely new blogging program easier than doing nothing?" Good point. Heh. erm...it's not easier but it is more fuitful.

Jeff H | July 19, 2006 09:49 AM

Don't sweat it John. Every now and again we all hit the same wall. A couple of months back I needed a lightweight webserver and so I tried installing thttpd. Everything was great until I tried to use cgi. It simply would not find my cgi directory. I poked around on forums, and some people were having the same problem, but there was no definitive solution. I got fed up and installed Apache, which worked right off the hop. Sometimes it's not you, it's the software.

Jeff

Ben Gray | July 19, 2006 09:51 AM

Apache rocks.

Jp | July 19, 2006 10:15 AM

What's the error message you're getting, John?

John Scalzi | July 19, 2006 10:39 AM

Can't replicate it at the moment; I've uninstalled 3.3. on my server (on the basis of better safe than sorry). I'll probably try again later (meaning in a couple of weeks, after I'm done with the book).

clvrmnky | July 19, 2006 11:05 AM

Don't forget about Serendipity (http://www.s9y.org/). I set up a test system to move my home-grown blog over to a system that supports the various APIs I'd like. Dead simple and painless, and it migrated my old entries over with minimal pain via XML.

[Aside: Yes, it's PHP. Get over it. You know how you feel about bad PHP? I feel that way about bad Perl. The difference is that I'm not sure there is anyway to make _good_ Perl.]

Ted Lemon | July 19, 2006 12:06 PM

SQL injection. Need I say more? I'm a big fan of open source, but if it's written in PHP, it needs to be rewritten. One nice thing about the Perl DBI is that, at least historically, it was not subject to SQL injection attacks. Of course, the last time I used it was back in Perl 4 days, so maybe they've fixed that by now.

Justine Larbalestier | July 19, 2006 12:32 PM

Switching to WordPress (which I use and love) is a lot easier than, say, getting a novel written. Just saying.

Now I return to my own (overdue) novel . . .

Michael Rawdon | July 19, 2006 05:25 PM

If anyone thinks John's being stubborn (or something) in sticking with Movable Type rather than moving to Wordpress, well, I've been sitting on my own home-grown journalling software ("software" might be too kind a term for it, actually) for years due to sheer inertia.

(Years?  Well, I started journalling shortly before the term 'weblog' was coined.)

That said, I'm planning to move to some real software sometime soon, and yeah, I'm planning to move to Wordpress.

But I can totally understand wanting to stick with what's working.

Christopher Davis | July 21, 2006 01:26 PM

I still haven't upgraded from MT 2.x, and I do this stuff (system administration) for a living. (That may be the reason, actually.)

John Romkey | July 24, 2006 10:18 AM

I used to use Movable Type on a small blog I was writing until I did an upgrade that seemed to succeed but managed to stop displaying my blog entries. I moved to Wordpress for my next blog and haven't had that level of problem yet. But you're right, switching to new software is definitely not easier than doing nothing.

If you decide to give MT 3.3 a shot again... here are a couple of suggestions:

First, Apache and mod_perl are very bad about showing helpful errors that might allow you to figure out what's actually going on. I've seen them often say that they can't find a Perl module when what they mean is that they can't load a Perl module. If you have shell access, I'd suggest trying the following from the command-line:

perl -w bootstrap.pm

from whatever directory bootstrap.pm is in. Backup your MT database and directory first, please.

If this gives you warnings then that'll give you a good place to start from. If the warnings say things like "cannot find Apache::...", they're caused by the fact that bootstrap.pm wasn't invoked from inside Apache and are probably safe to ignore. Other problems will need to be fixed.

If bootstrap.pm succeeds, or you don't have shell access, and you do have access to your Apache log files, try to do the MT 3.3 install process and take a look at error_log to see if it shows any errors. You probably did this and that's probably where you saw it claiming it couldn't find bootstrap.pm, but just in case you didn't, it might hold a clue as to what's going on.

Good luck.